const regex = /^/(((?!/).)+)-(\d+)\.html$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\/(((?!\/).)+)-(\\d+)\\.html$', '')
const str = `/foo-bar-article-9888--------1234.html`;
const subst = `/$3/$1-$3.html;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);