#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<a (?:(?!<a[^>]*>).)*?\$\{[^}]+\}.*?<\/a>"
Local $sString = "<a href="/foo">foo</a> some sample text <a href="${bar}">bar</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")