using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a (?:(?!<a[^>]*>).)*?\$\{[^}]+\}.*?<\/a>";
string input = @"<a href=""/foo"">foo</a> some sample text <a href=""${bar}"">bar</a>";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}