$re = '/<a (?:(?!<a[^>]*>).)*?\$\{[^}]+\}.*?<\/a>/i';
$str = '<a href="/foo">foo</a> some sample text <a href="${bar}">bar</a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);