re = /<a (?:(?!<a[^>]*>).)*?\$\{[^}]+\}.*?<\/a>/i
str = '<a href="/foo">foo</a> some sample text <a href="${bar}">bar</a>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end