using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^""]*""|\([^)]*\)";
string substitution = @"\1";
string input = @"AFGHANISTAN (AF)
LAND ISLANDS (AX)
ALBANIA (AL)
ALGERIA (DZ)
AMERICAN SAMOA (AS)
ANDORRA (AD)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}