re = /[^"]*"|\([^)]*\)/
str = 'AFGHANISTAN (AF)
LAND ISLANDS (AX)
ALBANIA (AL)
ALGERIA (DZ)
AMERICAN SAMOA (AS)
ANDORRA (AD)'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result