#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(2\d\d\d)-(\d|0\d|1[012])-(\d|[012]\d|3[01])$"
Local $sString = "2015-12-31" & @CRLF & _
"2015-12-11" & @CRLF & _
"2015-03-01" & @CRLF & _
"2015-03-1" & @CRLF & _
"2015-3-1" & @CRLF & _
"2015-9-31" & @CRLF & _
"" & @CRLF & _
"2015-13-31" & @CRLF & _
"2015-00-35" & @CRLF & _
"2015-12-39"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")