$re = '/^(2\d\d\d)-(\d|0\d|1[012])-(\d|[012]\d|3[01])$/m';
$str = '2015-12-31
2015-12-11
2015-03-01
2015-03-1
2015-3-1
2015-9-31
2015-13-31
2015-00-35
2015-12-39';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);