const regex = /^(2\d\d\d)-(\d|0\d|1[012])-(\d|[012]\d|3[01])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(2\\d\\d\\d)-(\\d|0\\d|1[012])-(\\d|[012]\\d|3[01])$', 'gm')
const str = `2015-12-31
2015-12-11
2015-03-01
2015-03-1
2015-3-1
2015-9-31
2015-13-31
2015-00-35
2015-12-39`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}