// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(2\d\d\d)-(\d|0\d|1[012])-(\d|[012]\d|3[01])$").unwrap();
let string = "2015-12-31
2015-12-11
2015-03-01
2015-03-1
2015-3-1
2015-9-31
2015-13-31
2015-00-35
2015-12-39";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}