using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G\s?,\s?|^)(\w+)\/(\w+)(?:\+(\w+))?|(?<!^)\G(?:\s?;\s?(\w+)=([\w\.]+))";
string input = @"application/xhtml+xml; q=0.9; level=3 , text/html,application/json;test=hello
application/xhtml+xml; q=3; age=9; text/html image/png;mime=none
,application/xhtml+xml; q=3; age=9; text/html application/json;test=hello
application/xhtml+xml; q=3; age=9 text/html , application/json;test=hello";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}