import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G\\s?,\\s?|^)(\\w+)\\/(\\w+)(?:\\+(\\w+))?|(?<!^)\\G(?:\\s?;\\s?(\\w+)=([\\w\\.]+))";
final String string = "application/xhtml+xml; q=0.9; level=3 , text/html,application/json;test=hello\n\n"
+ "application/xhtml+xml; q=3; age=9; text/html image/png;mime=none\n\n"
+ ",application/xhtml+xml; q=3; age=9; text/html application/json;test=hello\n\n"
+ "application/xhtml+xml; q=3; age=9 text/html , application/json;test=hello";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}