const regex = /(?:\G\s?,\s?|^)(\w+)\/(\w+)(?:\+(\w+))?|(?<!^)\G(?:\s?;\s?(\w+)=([\w\.]+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G\\s?,\\s?|^)(\\w+)\\\/(\\w+)(?:\\+(\\w+))?|(?<!^)\\G(?:\\s?;\\s?(\\w+)=([\\w\\.]+))', 'gm')
const str = `application/xhtml+xml; q=0.9; level=3 , text/html,application/json;test=hello
application/xhtml+xml; q=3; age=9; text/html image/png;mime=none
,application/xhtml+xml; q=3; age=9; text/html application/json;test=hello
application/xhtml+xml; q=3; age=9 text/html , application/json;test=hello`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}