re = /(?:\G\s?,\s?|^)(\w+)\/(\w+)(?:\+(\w+))?|(?<!^)\G(?:\s?;\s?(\w+)=([\w\.]+))/m
str = 'application/xhtml+xml; q=0.9; level=3 , text/html,application/json;test=hello
application/xhtml+xml; q=3; age=9; text/html image/png;mime=none
,application/xhtml+xml; q=3; age=9; text/html application/json;test=hello
application/xhtml+xml; q=3; age=9 text/html , application/json;test=hello'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end