using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(public)*\s*class\s+(\S+)\s+";
string input = @"public class hello {
public class hello extends jframe implement runable{";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}