re = /(public)*\s*class\s+(\S+)\s+/
str = 'public class hello {
public class hello extends jframe implement runable{'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end