package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(public)*\s*class\s+(\S+)\s+`)
var str = `public class hello {
public class hello extends jframe implement runable{`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}