$re = '/(public)*\s*class\s+(\S+)\s+/';
$str = 'public class hello {
public class hello extends jframe implement runable{';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);