using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d{12,22}\b";
string input = @"ESN: 355496930746061, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 35722223989377, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 354553495098527, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 350448885354834, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 352917263813650, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 351646277216193, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 357883403755026, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 352917262541195, Shipper:";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}