re = /\b\d{12,22}\b/m
str = 'ESN: 355496930746061, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 35722223989377, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 354553495098527, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 350448885354834, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 352917263813650, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 351646277216193, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 357883403755026, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 352917262541195, Shipper:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end