#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\(category[^ ]*\)"
Local $sString = "<CRIT> 23-Jun-2014::10:57:13.649 Upgrade committed" & @CRLF & _
"<CRIT> 23-Jun-2014::10:57:13.703 no registration found for callpoint plmsView/get_next of type=external" & @CRLF & _
"<CRIT> 23-Jun-2014::10:57:13.703 no registration found for callpoint View/get_next of type=external" & @CRLF & _
"" & @CRLF & _
"http://yxuy5oau7nugw4kpb4lclrqdbixp3wvc4iuiad23ebyp2q3gx7rtrgqd.onion/items/crystal-meth-10g-mdma/refunds-policy" & @CRLF & _
"" & @CRLF & _
"http://yxuy5oau7nugw4kpb4lclrqdbixp3wvc4iuiad23ebyp2q3gx7rtrgqd.onion/items/category/tutorials-and-e-books"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)