using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(category[^ ]*\)";
string substitution = @"";
string input = @"<CRIT> 23-Jun-2014::10:57:13.649 Upgrade committed
<CRIT> 23-Jun-2014::10:57:13.703 no registration found for callpoint plmsView/get_next of type=external
<CRIT> 23-Jun-2014::10:57:13.703 no registration found for callpoint View/get_next of type=external
http://yxuy5oau7nugw4kpb4lclrqdbixp3wvc4iuiad23ebyp2q3gx7rtrgqd.onion/items/crystal-meth-10g-mdma/refunds-policy
http://yxuy5oau7nugw4kpb4lclrqdbixp3wvc4iuiad23ebyp2q3gx7rtrgqd.onion/items/category/tutorials-and-e-books";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}