import re
regex = re.compile(r"\(category[^ ]*\)")
test_str = ("<CRIT> 23-Jun-2014::10:57:13.649 Upgrade committed\n"
"<CRIT> 23-Jun-2014::10:57:13.703 no registration found for callpoint plmsView/get_next of type=external\n"
"<CRIT> 23-Jun-2014::10:57:13.703 no registration found for callpoint View/get_next of type=external\n\n"
"http://yxuy5oau7nugw4kpb4lclrqdbixp3wvc4iuiad23ebyp2q3gx7rtrgqd.onion/items/crystal-meth-10g-mdma/refunds-policy\n\n"
"http://yxuy5oau7nugw4kpb4lclrqdbixp3wvc4iuiad23ebyp2q3gx7rtrgqd.onion/items/category/tutorials-and-e-books")
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)