#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)define service\s\{.*(Service 2|Command B).*\}"
Local $sString = "define service {" & @CRLF & _
" service_description Service 1" & @CRLF & _
" use Template 1" & @CRLF & _
" host_name Host 1" & @CRLF & _
" check_command Command A" & @CRLF & _
"}" & @CRLF & _
"define service {" & @CRLF & _
" service_description Service 2" & @CRLF & _
" use Template 1" & @CRLF & _
" host_name Host 1" & @CRLF & _
" check_command Command B" & @CRLF & _
"}" & @CRLF & _
"define service {" & @CRLF & _
" service_description Service 3" & @CRLF & _
" use Template 1" & @CRLF & _
" host_name Host 1" & @CRLF & _
" check_command Command C" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")