import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "define service\\s\\{.*(Service 2|Command B).*\\}";
final String string = "define service {\n"
+ " service_description Service 1\n"
+ " use Template 1\n"
+ " host_name Host 1\n"
+ " check_command Command A\n"
+ "}\n"
+ "define service {\n"
+ " service_description Service 2\n"
+ " use Template 1\n"
+ " host_name Host 1\n"
+ " check_command Command B\n"
+ "}\n"
+ "define service {\n"
+ " service_description Service 3\n"
+ " use Template 1\n"
+ " host_name Host 1\n"
+ " check_command Command C\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}