import re
regex = re.compile(r"define service\s\{.*(Service 2|Command B).*\}", flags=re.DOTALL)
test_str = ("define service {\n"
" service_description Service 1\n"
" use Template 1\n"
" host_name Host 1\n"
" check_command Command A\n"
"}\n"
"define service {\n"
" service_description Service 2\n"
" use Template 1\n"
" host_name Host 1\n"
" check_command Command B\n"
"}\n"
"define service {\n"
" service_description Service 3\n"
" use Template 1\n"
" host_name Host 1\n"
" check_command Command C\n"
"}")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")