using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?href=""(.*?)"".*?>(.*?)?<\/a>";
string input = @"on <a href=""https://www.reddit.com/"" target=""_blank"" rel=""noopener"">reddit</a> or <a href=""https://lifehacker.com/"" target=""_blank"" rel=""noopener"">Lifehacker</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}