package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a.*?href="(.*?)".*?>(.*?)?<\/a>`)
var str = `on <a href="https://www.reddit.com/" target="_blank" rel="noopener">reddit</a> or <a href="https://lifehacker.com/" target="_blank" rel="noopener">Lifehacker</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}