re = /<a.*?href="(.*?)".*?>(.*?)?<\/a>/m
str = 'on <a href="https://www.reddit.com/" target="_blank" rel="noopener">reddit</a> or <a href="https://lifehacker.com/" target="_blank" rel="noopener">Lifehacker</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end