import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?\\P{L}*?(\\p{L}+-?(\\p{L}+)?)\\P{L}*$";
final String string = "Veel maatschappen worden opgericht door mensen met een vrij beroep , zoals arts en , \n"
+ "\" Het is leuk 'n \n"
+ "Een goede fiscalist / \n"
+ "Dan kan hij 'n heel leger de baas , 'n \n"
+ "Ik zou denken van wel , eens deze kerel verdwenen zullen er nog erger aan de macht komen , mensen , crimineel krankzinnig , en fanatiek godsdienstig genoeg om met atoombommen naar het westen te smijten...Die \n"
+ "Wie o wie weet er een betaalbare #\n"
+ "De CEO(Chief Executive Officer , algemeen directeur ) en de CFO(Chief Financial Officer , financieel directeur ) moeten een plechtige verklaring afleggen dat alle controles waterdicht zijn en de auditor ( \n"
+ "U dient daarbij als verantwoordelijke voor de mutatie-officier ' \n"
+ "Vengaboys ( spreek uit : Bengaboys ) is een Nederlandse dance - \n"
+ "Hendriks = J.N. Schouten, ";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}