package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`T12345 .{1,100}[\n\r].{1,100}2014.03.04`)
var str = `must satisfy regular expression pattern: \w{1,100}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}