$re = '/T12345 .{1,100}[\n\r].{1,100}2014.03.04/';
$str = 'must satisfy regular expression pattern: \\w{1,100}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);