re = /T12345 .{1,100}[\n\r].{1,100}2014.03.04/
str = 'must satisfy regular expression pattern: \\w{1,100}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end