import Foundation
let pattern = #"T12345 .{1,100}[\n\r].{1,100}2014.03.04"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"must satisfy regular expression pattern: \w{1,100}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}