using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([£\$])*([\d,.]*)";
string input = @"20,000.00 - 24,000.00 per year
£25,000.00 - £30,000.00 per year£25000 - £30000/annum
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}