$re = '/([£\$])*([\d,.]*)/';
$str = '20,000.00 - 24,000.00 per year
£25,000.00 - £30,000.00 per year£25000 - £30000/annum
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);