re = /([£\$])*([\d,.]*)/
str = '20,000.00 - 24,000.00 per year
£25,000.00 - £30,000.00 per year£25000 - £30000/annum
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end