package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([£\$])*([\d,.]*)`)
var str = `20,000.00 - 24,000.00 per year
£25,000.00 - £30,000.00 per year£25000 - £30000/annum
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}