#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i){([a-z][\w]+)(?::(?:(\/(?:.+?)\/i?)|(?:([a-z]+)(?:\[(\d+)?(,)?(\d+)?])?)))?}"
Local $sString = "{name:/abc/}_{id:/[qwerty]/}_{str}_{string:type}_{test:test[1,2]}_{test:test[1]}_{test:/\d+/}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")