import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{([a-z][\\w]+)(?::(?:(\\/(?:.+?)\\/i?)|(?:([a-z]+)(?:\\[(\\d+)?(,)?(\\d+)?])?)))?\\}";
final String string = "{name:/abc/}_{id:/[qwerty]/}_{str}_{string:type}_{test:test[1,2]}_{test:test[1]}_{test:/\\d+/}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}