package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i){([a-z][\w]+)(?::(?:(\/(?:.+?)\/i?)|(?:([a-z]+)(?:\[(\d+)?(,)?(\d+)?])?)))?}`)
var str = `{name:/abc/}_{id:/[qwerty]/}_{str}_{string:type}_{test:test[1,2]}_{test:test[1]}_{test:/\d+/}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}