$re = '/{([a-z][\w]+)(?::(?:(\/(?:.+?)\/i?)|(?:([a-z]+)(?:\[(\d+)?(,)?(\d+)?])?)))?}/i';
$str = '{name:/abc/}_{id:/[qwerty]/}_{str}_{string:type}_{test:test[1,2]}_{test:test[1]}_{test:/\\d+/}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);