using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\s+([A-Z]+)(\d+)\s+(\w+)";
string substitution = @"$1+$2+$3+$4";
string input = @"6876786786 GFS8978976 I
6786786767 DDF78676 I
4343245443 SBSSK67676 I
8393372263 SBSSK56565 I
6545434347 DDF7878333 I
6757650000 SBSSK453 I";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}