import Foundation
let pattern = #"(\d+)\s+([A-Z]+)(\d+)\s+(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
6876786786 GFS8978976 I
6786786767 DDF78676 I
4343245443 SBSSK67676 I
8393372263 SBSSK56565 I
6545434347 DDF7878333 I
6757650000 SBSSK453 I
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1+$2+$3+$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)