import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\s+([A-Z]+)(\\d+)\\s+(\\w+)";
final String string = "6876786786 GFS8978976 I\n"
+ "6786786767 DDF78676 I\n"
+ "4343245443 SBSSK67676 I\n"
+ "8393372263 SBSSK56565 I\n"
+ "6545434347 DDF7878333 I\n"
+ "6757650000 SBSSK453 I";
final String subst = "$1+$2+$3+$4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}