re = /(\d+)\s+([A-Z]+)(\d+)\s+(\w+)/
str = '6876786786 GFS8978976 I
6786786767 DDF78676 I
4343245443 SBSSK67676 I
8393372263 SBSSK56565 I
6545434347 DDF7878333 I
6757650000 SBSSK453 I'
subst = '$1+$2+$3+$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result