#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*\[[^\[\]]*\]\s*=\s*\{[^{}]*\["life"\]\s*=\s*"No"[^{}]*}"
Local $sString = "universe = {" & @CRLF & _
" ["stars"] = {" & @CRLF & _
" ["Sun"] = {" & @CRLF & _
" ["planets"] = "9"," & @CRLF & _
" ["life"] = "Yes"," & @CRLF & _
" ["asteroid"] = "9001"" & @CRLF & _
" }," & @CRLF & _
" ["Alpha Centauri"] = {" & @CRLF & _
" ["planets"] = "3"," & @CRLF & _
" ["life"] = "No"," & @CRLF & _
" ["asteroid"] = "20"" & @CRLF & _
" }," & @CRLF & _
" ["Rigel"] = {" & @CRLF & _
" ["planets"] = "5"," & @CRLF & _
" ["life"] = "No"," & @CRLF & _
" ["asteroid"] = "11"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")