using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\[[^\[\]]*\]\s*=\s*\{[^{}]*\[""life""\]\s*=\s*""No""[^{}]*}";
string input = @"universe = {
[""stars""] = {
[""Sun""] = {
[""planets""] = ""9"",
[""life""] = ""Yes"",
[""asteroid""] = ""9001""
},
[""Alpha Centauri""] = {
[""planets""] = ""3"",
[""life""] = ""No"",
[""asteroid""] = ""20""
},
[""Rigel""] = {
[""planets""] = ""5"",
[""life""] = ""No"",
[""asteroid""] = ""11""
}
}
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}