# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*\[[^\[\]]*\]\s*=\s*\{[^{}]*\[\"life\"\]\s*=\s*\"No\"[^{}]*}"
test_str = ("universe = {\n"
" [\"stars\"] = {\n"
" [\"Sun\"] = {\n"
" [\"planets\"] = \"9\",\n"
" [\"life\"] = \"Yes\",\n"
" [\"asteroid\"] = \"9001\"\n"
" },\n"
" [\"Alpha Centauri\"] = {\n"
" [\"planets\"] = \"3\",\n"
" [\"life\"] = \"No\",\n"
" [\"asteroid\"] = \"20\"\n"
" },\n"
" [\"Rigel\"] = {\n"
" [\"planets\"] = \"5\",\n"
" [\"life\"] = \"No\",\n"
" [\"asteroid\"] = \"11\"\n"
" }\n"
" }\n"
"}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.